wiki:FAQ

Version 9 (modified by leo, 3 years ago) (diff)

--

General Questions

1. The array command doesn't do anything, what's going on?

You must set the total number of bricks in the array to a value greater than 1.

2. How can I set the default options for a new project?

Open the Properties Dialog under the File Menu, set the options you want and check the 'Set Default' checkbox. LeoCAD will save those options and use them next time you start a new project.

3. I can't seem to align two bricks correctly, they are always away from each other.

Most of the times when this happens it's because the bricks are not where you think they are, they are actually far away and because of the perspective distortion you think they are near each other. Take a look at the picture and compare the Top and Side views with the Main view.

4. How can I export a model to use with LDraw?

Just choose the "Save As" option from the "File" menu and enter a file name with the .dat or .ldr extension.

5. I found a new LDraw piece and I would like to use it in LeoCAD, how do I add it to the library?

Just place the piece and all its unofficial subpieces and primitives properly in the LDraw folder (you must have the LDraw library installed to do this).

Open LeoCAD, go to the Preferences Dialog (in the View menu), go to the General tab and then enter the path to the LDraw library on the Custom Library field.

6. How can I create new pieces?

LeoCAD uses the LDraw file format for pieces, you can find out more information about the format and the tools used to create pieces on the LDraw website.

Linux Questions

1. Where can I find libGL.so?

If you don't have any OpenGL libraries installed you can use Mesa 3D, make sure that you add the directory where you installed it to your /etc/ld.so.conf file and run ldconfig or have it in your LD_LIBRARY_PATH environment variable.

2. I get the error "_mesa_unpack_ubyte_color_span: Assertion `dstComponents > 0' failed." when I try to run LeoCAD.

This is a problem caused by old versions of the Mesa 3D library (the version that comes with RedHat 6.2 for example). Go to the Mesa Homepage, download and install a newer version.