Changes between Version 4 and Version 5 of MovingPieces


Ignore:
Timestamp:
Feb 21, 2006 4:50:55 PM (10 years ago)
Author:
dulcaoin@…
Comment:

text clean up, some reworking of text flow.

Legend:

Unmodified
Added
Removed
Modified
  • MovingPieces

    v4 v5  
    11== Moving pieces ==
    22
    3 Selected pieces or group of pieces can be moved using the "move" tool (toolbar icon [[Image(arrow_icons.png, nolink)]])
     3Pieces (or groups of pieces) that have been selected can be moved using the Move tool (toolbar icon [[Image(arrow_icons.png, nolink)]])
    44
    5 '''''Tip:''' you are automatically switched to move function after adding a new piece if this option is enabled in preference menu ("Preferences" under the "View" menu, then go to the "Drawing Aids" tab and checking the box "Switch to move after inserting").'''
     5'''''Tip:''' LeoCAD automatically switches to the Move function after adding a new piece if this option has been enabled via the Preferences menu (Select the View menu, click "Preferences", select the "Drawing Aids" tab and check "Switch to move after inserting").'''
    66
    7 Move can be performed using the keyboard. With default keys, arrow keys move piece in XY plane while !PageUp/PageDown move along Z axis. But the easiest way uses mouse click-and-drag operations as illustrated below.
     7Movement of pieces can be performed using the keyboard. By default, the arrow keys move pieces along the X-axis and Y-axis, while the !PageUp and !PageDown keys move pieces along the Z-axis.
    88
    9 ||[[Image(move_arrows-1.png, nolink)]]|| In move mode, a colored three arrows overlay appears on the selected piece.||
    10 ||[[Image(y_move-1.png, nolink)]][[BR]][[Image(y_moved-1.png, nolink)]]|| Place the cursor near an arrow, when you are close enough it turns yellow. If you Click and drag that arrow, the piece will move along selected axis.||
    11 ||[[Image(xyz_axis.png, nolink)]]|| Red arrow is the X axis. [[BR]]Green arrow is the Y axis. [[BR]]Blue arrow is the Z axis. ||
    12 ||[[Image(yz_move-1.png, nolink)]][[BR]][[Image(yz_moved-1.png, nolink)]]|| If the mouse cursor is close enough to the origin of the arrows, a small yellow square appears between two arrows which turn yellow. Click and drag to move the piece in the plane defined by these axis.||
    13 ||[[Image(xyz_coords.png, nolink)]]|| You can follow piece position using the [wiki:CoordinatesDisplay coordinates display] on the right of the status bar.||
     9
     10A more interactive method uses mouse click-and-drag operations as illustrated below.
     11
     12||[[Image(move_arrows-1.png, nolink)]]|| In Move mode, a three-colored overlay appears on the selected piece, representing the X, Y, and Z axes.||
     13||[[Image(y_move-1.png, nolink)]][[BR]][[Image(y_moved-1.png, nolink)]]|| Move the mouse cursor towards an arrow until it turns yellow, then Click and Drag the mouse along the arrow to move the piece along the corresponding axis.||
     14||[[Image(xyz_axis.png, nolink)]]|| The red arrow represents the X-axis, while green represents the Y-axis and blue represents the Z-Axis. ||
     15||[[Image(yz_move-1.png, nolink)]][[BR]][[Image(yz_moved-1.png, nolink)]]|| If the mouse cursor is moved towards the origin of the arrows (where they meet), a yellow square appears between two arrows, which will both turn yellow. Click and Drag the mouse to move the piece in the plane defined by these axis.||
     16||[[Image(xyz_coords.png, nolink)]]|| The position of the piece will be displayed, live, via the [wiki:CoordinatesDisplay coordinates display] on the right-hand side of the status bar along the bottom of the LeoCAD window.||
    1417||'''Snap Grid'''||Piece movements occur in discrete chunks, controlled by the [wiki:SnapGrid snap grid]. You can change the size of these steps or disable partially or totally the snap action: see [wiki:SnapGrid snap grid control].||
    1518||[[Image(modify_dlg.png, nolink)]]||You can also move a piece using the "Piece Modify" dialog box. [[BR]]To get to this dialog box, check "Modify" in the "View" menu. Select a piece, enter its new [wiki:CoordinatesDisplay X/Y/Z coordinates] and click on the "Apply" button.||